- Creeper

Annons

In English: Prestashop 1.6 ”no carrier”-issues

I write this in English to hopefully help someone who runs into the same problem I did. My regular readers who don’t have a Prestashop-webshop running may skip this post completely. It will not be interesting.

Yesterday I updated my shop from Prestashop 1.5.2 to 1.6. I anticipated some problems but I got this super-weird issue with carriers. No matter how I tried to set the carriers, countries and zones, I would always get ”no carrier available for your address” on check-out. Finally I narrowed it down to an issue with the stock management and warehouse!

I have been fiddling with different countries in my back-office before, to try to get some differentiated prices for different customer groups (not very successful), and somehow now with the upgrade to 1.6, it messed up the country that my ”warehouse” (my home) was assigned. Therefore the carrier-module would say no carrier could deliver to my address, when in fact the problem was that the carrier couldn’t deliver FROM my warehouse! I went into the warehouse settings, made sure the country was correct and saved the changes and what do you know – it works!

So, if you have weird problems with ”no carrier” after upgrading Prestashop, go check your warehouses to see if they are correctly set up. I hope this is useful to someone. 🙂

4 comments to In English: Prestashop 1.6 ”no carrier”-issues

  • […] maybe few of you have already this problems……..simple words is i already done what i can to setting zones, until shipping settings but why still when i check this “yhere’s no carrier in my country” so i check and check in web…..voila i found this http://blogg.grevadl…carrier-issues/ […]

  • THANK YOU, THANK YOU, THANK YOU!!!! I also suspected it had something to do with the stock management. I could not get my products to even show up without using the advanced stock setup, and I was so frustrated with the hours and hours I spent figuring that out, that I did miss 2 details in the warehouse setup! I did not get my ZIP CODE entered & I had not selected a carrier (because that was BEFORE I figured out how to install the USPS module). So many details to remember! I was really about to GIVE UP!!! So glad I found this info in my search! RELIEF!!! Now if I can just get the payment setup going!

  • Lukas

    I searched for hours for this solution. Thank you so much!

  • Gustavo

    Same problem here and alot of research and no answer by now.

Leave a Reply

You can use these HTML tags

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

  

  

  

CAPTCHA

*